What are the Device and OS Requirements of the TruckLogics Application?
445 views | Last modified 12/15/2022 1:52:02 AM EST | Added by TruckLogics Team

Applicable To
Fleet Managers Drivers Leased Operators Owner Operators Brokers IFTA Reporting

To eliminate the chances of our users facing any usability issues with our application, TruckLogics frequently update its device requirements.

Web browsers:
 

The TruckLogics application is supported only in the browsers with the versions specified as follows.

Chrome  

Supported in the two latest released versions.

Microsoft Edge

Supported in the two latest versions of the new Microsoft Edge (Chromium-based).

Firefox 

Supported in the two latest released versions. Firefox versions older than two major versions, including Extended Support Release (ESR) versions, are not supported.

Safari 

Supported in the two latest released versions on macOS (as specified in the OS section below).


Operating systems (OS):
 

The TruckLogics application is supported only in the devices with the OS versions specified below.


Windows & Windows Server

Supported in the two latest released versions (64-bit)


macOS 

Supported in the two latest major versions. 


Android

Supported in the Android versions 11 and above.


iOS 

Supported in the two latest released versions.


Understanding the TruckLogics Compatability Policy
 

  • Whenever a new version of the OS or browser is released, TruckLogics begins supporting the update, continues supporting the most latest versions, and ends support for the previous versions.
  • This End of Life (EOL) policy is standard for browsers and OS.
  • We recommend you keep the most recent versions of the TruckLogics application. There may be fixes in the new version for any issues you may have faced with an older version.  If you have not updated, our Product Support team will recommend the same during the support process.
  • TruckLogics will end the support for third-party dependencies on the same day when the vendor ends support for the software. TruckLogics will make sufficient efforts to provide enough lead time to upgrade to the supported version of 3rd party libraries.
  • TruckLogics has the right to make exceptions from this policy in case of any conflicts or security issues.
     

Was this helpful? Yes No

Sign Up for a
FREE TruckLogics Account!

Register Now

Returning User? Sign in

Couldn't find what you
are looking for?

Contact Us

(704) 234-6946 [email protected]